Power outage
Incident Report for Vale WISP Ltd
Resolved
SPEN has re energised the line and the network is now functioning as expected. This outage is now resolved.
Posted Apr 13, 2023 - 15:24 UTC
Monitoring
Affecting some customers in Llangynhafal, Bontuchel, Clocaenog.

A mast has been de-energized whilst SPEN engineers work on the power lines, we are usually warned about this in advance but this time we were not.

SPEN are due to have power restored by 4 pm.

We apologise for any inconvenience caused, as well as the lack of advanced warning.
Posted Apr 13, 2023 - 11:05 UTC